summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db40db7..9bf2b2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,8 +9,8 @@ INCLUDE(CTest)
INCLUDE(GetGitRevisionDescription)
get_git_head_revision(GIT_REFSPEC GIT_SHA1)
-# C99
-ADD_DEFINITIONS(-std=c99)
+# C99 and _GNU_SOURCE for secure_getenv
+ADD_DEFINITIONS(-std=c99 -D_GNU_SOURCE)
# Compile library
ADD_SUBDIRECTORY(lib)