summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index aceaaf5..6af4e3e 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -1,7 +1,7 @@
# Sources
SET(CLIENT_SOURCE client.c)
-SET(CLIENT_INCLUDE "${CMAKE_CURRENT_SOURCE_DIR}/../lib")
-SET(CLIENT_LIBRARIES bemenu)
+SET(CLIENT_INCLUDE ${BEMENU_INCLUDE_DIRS})
+SET(CLIENT_LIBRARIES ${BEMENU_LIBRARIES})
# Warnings
IF (CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
@@ -20,5 +20,9 @@ ENDIF ()
INCLUDE_DIRECTORIES(${CLIENT_INCLUDE})
ADD_EXECUTABLE(client ${CLIENT_SOURCE})
TARGET_LINK_LIBRARIES(client ${CLIENT_LIBRARIES})
+SET_TARGET_PROPERTIES(client PROPERTIES OUTPUT_NAME bemenu)
+
+# Install
+INSTALL(TARGETS client DESTINATION bin)
# vim: set ts=8 sw=4 tw=0 :