From 5ca32626dc603dfddcf833c762174b4260b8af2c Mon Sep 17 00:00:00 2001
From: Danilo Spinella <danyspin97@protonmail.com>
Date: Sun, 24 Mar 2019 14:57:48 +0100
Subject: Add options for renderers, make deps required

---
 lib/renderers/CMakeLists.txt | 22 +++++++++++++++++-----
 1 file changed, 17 insertions(+), 5 deletions(-)

(limited to 'lib/renderers/CMakeLists.txt')

diff --git a/lib/renderers/CMakeLists.txt b/lib/renderers/CMakeLists.txt
index ef85317..a3350c7 100644
--- a/lib/renderers/CMakeLists.txt
+++ b/lib/renderers/CMakeLists.txt
@@ -1,8 +1,20 @@
-SET(RENDERERS
-    "curses"
-    "wayland"
-    "x11"
-)
+SET(RENDERERS "")
+
+IF(BEMENU_CURSES_RENDERER)
+    LIST(APPEND RENDERERS "curses")
+ENDIF()
+
+IF(BEMENU_X11_RENDERER)
+    LIST(APPEND RENDERERS "x11")
+ENDIF()
+
+IF(BEMENU_WAYLAND_RENDERER)
+    LIST(APPEND RENDERERS "wayland")
+ENDIF()
+
+IF(NOT RENDERERS)
+    MESSAGE(FATAL_ERROR "At least one renderer should be enabled")
+ENDIF()
 
 ADD_DEFINITIONS(-DPANGO_DISABLE_DEPRECATED)
 
-- 
cgit v1.2.3-70-g09d2