summaryrefslogtreecommitdiff
path: root/run.m1.spec
diff options
context:
space:
mode:
authorNate Sesti <33237525+sestinj@users.noreply.github.com>2023-08-23 14:44:33 -0700
committerGitHub <noreply@github.com>2023-08-23 14:44:33 -0700
commit0c563fc28fefa0cd7181fd78c579c3a86faaa4f9 (patch)
treeb67514fc49c7d19821d1a7f03579259b2948cc48 /run.m1.spec
parentc5211c2cd69f368cc564aad155080957b754de19 (diff)
downloadsncontinue-0c563fc28fefa0cd7181fd78c579c3a86faaa4f9.tar.gz
sncontinue-0c563fc28fefa0cd7181fd78c579c3a86faaa4f9.tar.bz2
sncontinue-0c563fc28fefa0cd7181fd78c579c3a86faaa4f9.zip
Testing gh workflow (#401)
* testing * logging again * log home dir * build m1 script * correctly parse dates in history.tsx * logging * add redbaron to requirements.txt * tweaks before merging to main
Diffstat (limited to 'run.m1.spec')
-rw-r--r--run.m1.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/run.m1.spec b/run.m1.spec
new file mode 100644
index 00000000..3eeea867
--- /dev/null
+++ b/run.m1.spec
@@ -0,0 +1,47 @@
+# -*- mode: python ; coding: utf-8 -*-
+import certifi
+
+block_cipher = None
+
+
+a = Analysis(
+ ['run.py'],
+ pathex=[],
+ binaries=[],
+ datas=[
+ ('continuedev', 'continuedev'),
+ (certifi.where(), 'ca_bundle')
+ ],
+ hiddenimports=['anthropic', 'github', 'ripgrepy', 'bs4', 'redbaron'],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=['numpy', 'jedi'],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False,
+)
+pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
+
+exe = EXE(
+ pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name='run',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=True,
+ disable_windowed_traceback=False,
+ argv_emulation=False,
+ target_arch="arm64",
+ codesign_identity=None,
+ entitlements_file=None,
+)