summaryrefslogtreecommitdiff
path: root/run.m1.spec
diff options
context:
space:
mode:
authorNate Sesti <sestinj@gmail.com>2023-08-26 11:04:14 -0700
committerNate Sesti <sestinj@gmail.com>2023-08-26 11:04:14 -0700
commitb0426d82a4871e9081367ad4e977b22f42db5a89 (patch)
tree54e93f5d263044088b3b938a10856a7d8907bbd8 /run.m1.spec
parente1200c0e725bd46304899349f472a91442ee76ad (diff)
downloadsncontinue-b0426d82a4871e9081367ad4e977b22f42db5a89.tar.gz
sncontinue-b0426d82a4871e9081367ad4e977b22f42db5a89.tar.bz2
sncontinue-b0426d82a4871e9081367ad4e977b22f42db5a89.zip
fix: :construction_worker: copy_metadata for replicate in run.spec
Diffstat (limited to 'run.m1.spec')
-rw-r--r--run.m1.spec7
1 files changed, 4 insertions, 3 deletions
diff --git a/run.m1.spec b/run.m1.spec
index 3eeea867..ad75856a 100644
--- a/run.m1.spec
+++ b/run.m1.spec
@@ -1,5 +1,6 @@
# -*- mode: python ; coding: utf-8 -*-
import certifi
+from PyInstaller.utils.hooks import copy_metadata
block_cipher = None
@@ -10,9 +11,9 @@ a = Analysis(
binaries=[],
datas=[
('continuedev', 'continuedev'),
- (certifi.where(), 'ca_bundle')
- ],
- hiddenimports=['anthropic', 'github', 'ripgrepy', 'bs4', 'redbaron'],
+ (certifi.where(), 'ca_bundle'),
+ ] + copy_metadata('replicate'),
+ hiddenimports=['anthropic', 'github', 'ripgrepy', 'bs4', 'redbaron', 'replicate'],
hookspath=[],
hooksconfig={},
runtime_hooks=[],