diff options
author | Nate Sesti <33237525+sestinj@users.noreply.github.com> | 2023-09-04 10:38:22 -0700 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-09-04 10:38:22 -0700 |
commit | b632a5ab537069e22b976b097b34b9879be18168 (patch) | |
tree | 5a5d21007312ff42c0a320d52c528ee09a9f9b28 /run.spec | |
parent | ec6523d35ac0e5c38a224418cb224d8421886449 (diff) | |
download | sncontinue-b632a5ab537069e22b976b097b34b9879be18168.tar.gz sncontinue-b632a5ab537069e22b976b097b34b9879be18168.tar.bz2 sncontinue-b632a5ab537069e22b976b097b34b9879be18168.zip |
Integrate LSP for debugging (#450)
* headless IDE subclass
* finish headless_ide methods
* feat: :sparkles: headless mode running with config flag
* work on debugging
* python lsp support
* more lsp+debugging work
* refactor: :safety_vest: safely load LSP
* test: :white_check_mark: testing steps in headless mode
* refactor: :clown_face: cleanup subprocesses
* fix: :bug: handle data: [DONE] from Together
Diffstat (limited to 'run.spec')
-rw-r--r-- | run.spec | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -12,8 +12,8 @@ a = Analysis( datas=[ ('continuedev', 'continuedev'), (certifi.where(), 'ca_bundle') - ] + copy_metadata('replicate'), - hiddenimports=['anthropic', 'github', 'ripgrepy', 'bs4', 'redbaron', 'replicate'], + ], + hiddenimports=['anthropic', 'github', 'ripgrepy', 'bs4', 'redbaron', 'python-lsp-server', 'replicate'] + copy_metadata('replicate'), hookspath=[], hooksconfig={}, runtime_hooks=[], |