summaryrefslogtreecommitdiff
path: root/run.spec
diff options
context:
space:
mode:
authorNate Sesti <sestinj@gmail.com>2023-08-08 11:34:14 -0700
committerNate Sesti <sestinj@gmail.com>2023-08-08 11:34:14 -0700
commitb82d83f79389897ed5f05eb9b5e8daf9cf64ee6f (patch)
tree352f07f52ea5aabb08b69f89c55ba571050df384 /run.spec
parent160723abdbc336afc260e5aa6b103b27c5c27909 (diff)
downloadsncontinue-b82d83f79389897ed5f05eb9b5e8daf9cf64ee6f.tar.gz
sncontinue-b82d83f79389897ed5f05eb9b5e8daf9cf64ee6f.tar.bz2
sncontinue-b82d83f79389897ed5f05eb9b5e8daf9cf64ee6f.zip
fix: :bug: add data file for ca_bundle
Diffstat (limited to 'run.spec')
-rw-r--r--run.spec47
1 files changed, 47 insertions, 0 deletions
diff --git a/run.spec b/run.spec
new file mode 100644
index 00000000..3bb46c73
--- /dev/null
+++ b/run.spec
@@ -0,0 +1,47 @@
+# -*- mode: python ; coding: utf-8 -*-
+import certifi
+
+block_cipher = None
+
+
+a = Analysis(
+ ['run.py'],
+ pathex=[],
+ binaries=[],
+ datas=[
+ ('continuedev', 'continuedev'),
+ (certifi.where(), 'ca_bundle')
+ ],
+ hiddenimports=['anthropic', 'github', 'ripgrepy'],
+ hookspath=[],
+ hooksconfig={},
+ runtime_hooks=[],
+ excludes=['numpy', 'jedi'],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False,
+)
+pyz = PYZ(a.pure, a.zipped_data, cipher=block_cipher)
+
+exe = EXE(
+ pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name='run',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=True,
+ disable_windowed_traceback=False,
+ argv_emulation=False,
+ target_arch=None,
+ codesign_identity=None,
+ entitlements_file=None,
+)