summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJari Vetoniemi <mailroxas@gmail.com>2014-10-25 16:39:39 +0300
committerJari Vetoniemi <mailroxas@gmail.com>2014-10-25 16:39:39 +0300
commitb03cd1ea5329a0e7e2e435de827108c7d00265b5 (patch)
treedeb501d382434c7ac556e3fc125f4ea730ca8a44 /CMakeLists.txt
parent92b9044da84f524dcbfae7eef4092b6240986a27 (diff)
downloadbemenu-b03cd1ea5329a0e7e2e435de827108c7d00265b5.tar.gz
bemenu-b03cd1ea5329a0e7e2e435de827108c7d00265b5.tar.bz2
bemenu-b03cd1ea5329a0e7e2e435de827108c7d00265b5.zip
Use BM_PLUGIN_VERSION for renderers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86f8b2e..db40db7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,14 @@
CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
PROJECT(bemenu)
-INCLUDE(CTest)
SET(BEMENU_NAME "bemenu")
SET(BEMENU_DESCRIPTION "Dynamic menu library and client program inspired by dmenu")
SET(BEMENU_VERSION "1.0.0")
SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${bemenu_SOURCE_DIR}/CMake)
+INCLUDE(CTest)
+INCLUDE(GetGitRevisionDescription)
+get_git_head_revision(GIT_REFSPEC GIT_SHA1)
+
# C99
ADD_DEFINITIONS(-std=c99)