summaryrefslogtreecommitdiff
path: root/lib/renderers/CMakeLists.txt
diff options
context:
space:
mode:
authorJari Vetoniemi <mailRoxas@gmail.com>2019-03-25 10:52:24 +0200
committerGitHub <noreply@github.com>2019-03-25 10:52:24 +0200
commitb375ef8b0bd2c40b4fc26bd0c4d38dcb4374c149 (patch)
treebb8fb87db0be7f207c98dbb79a44b4955fccf6f6 /lib/renderers/CMakeLists.txt
parent1be74a290f7ef9a0cc420ad98239c2f7dbb03165 (diff)
parent5ca32626dc603dfddcf833c762174b4260b8af2c (diff)
downloadbemenu-b375ef8b0bd2c40b4fc26bd0c4d38dcb4374c149.tar.gz
bemenu-b375ef8b0bd2c40b4fc26bd0c4d38dcb4374c149.tar.bz2
bemenu-b375ef8b0bd2c40b4fc26bd0c4d38dcb4374c149.zip
Merge pull request #46 from DanySpin97/master
Add options for renderers, make deps required
Diffstat (limited to 'lib/renderers/CMakeLists.txt')
-rw-r--r--lib/renderers/CMakeLists.txt22
1 files changed, 17 insertions, 5 deletions
diff --git a/lib/renderers/CMakeLists.txt b/lib/renderers/CMakeLists.txt
index ef85317..a3350c7 100644
--- a/lib/renderers/CMakeLists.txt
+++ b/lib/renderers/CMakeLists.txt
@@ -1,8 +1,20 @@
-SET(RENDERERS
- "curses"
- "wayland"
- "x11"
-)
+SET(RENDERERS "")
+
+IF(BEMENU_CURSES_RENDERER)
+ LIST(APPEND RENDERERS "curses")
+ENDIF()
+
+IF(BEMENU_X11_RENDERER)
+ LIST(APPEND RENDERERS "x11")
+ENDIF()
+
+IF(BEMENU_WAYLAND_RENDERER)
+ LIST(APPEND RENDERERS "wayland")
+ENDIF()
+
+IF(NOT RENDERERS)
+ MESSAGE(FATAL_ERROR "At least one renderer should be enabled")
+ENDIF()
ADD_DEFINITIONS(-DPANGO_DISABLE_DEPRECATED)