summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index cf489fd..e669ef5 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -1,6 +1,9 @@
# Sources
SET(BEMENU_SOURCE
- bemenu.c
+ menu.c
+ item.c
+ filter.c
+ util.c
draw/curses.c
)
SET(BEMENU_INCLUDE)
@@ -22,6 +25,6 @@ ENDIF ()
# Compile
INCLUDE_DIRECTORIES(${BEMENU_INCLUDE})
ADD_LIBRARY(bemenu ${BEMENU_SOURCE})
-TARGET_LINK_LIBRARIES(bemenu ${BEMENU_LIBRARIES})
+TARGET_LINK_LIBRARIES(bemenu ${BEMENU_LIBRARIES} dl)
# vim: set ts=8 sw=4 tw=0 :