summaryrefslogtreecommitdiff
path: root/lib/renderers/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/renderers/CMakeLists.txt')
-rw-r--r--lib/renderers/CMakeLists.txt22
1 files changed, 17 insertions, 5 deletions
diff --git a/lib/renderers/CMakeLists.txt b/lib/renderers/CMakeLists.txt
index ef85317..a3350c7 100644
--- a/lib/renderers/CMakeLists.txt
+++ b/lib/renderers/CMakeLists.txt
@@ -1,8 +1,20 @@
-SET(RENDERERS
- "curses"
- "wayland"
- "x11"
-)
+SET(RENDERERS "")
+
+IF(BEMENU_CURSES_RENDERER)
+ LIST(APPEND RENDERERS "curses")
+ENDIF()
+
+IF(BEMENU_X11_RENDERER)
+ LIST(APPEND RENDERERS "x11")
+ENDIF()
+
+IF(BEMENU_WAYLAND_RENDERER)
+ LIST(APPEND RENDERERS "wayland")
+ENDIF()
+
+IF(NOT RENDERERS)
+ MESSAGE(FATAL_ERROR "At least one renderer should be enabled")
+ENDIF()
ADD_DEFINITIONS(-DPANGO_DISABLE_DEPRECATED)