summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTuowen Zhao <ztuowen@gmail.com>2016-09-26 08:51:47 -0600
committerTuowen Zhao <ztuowen@gmail.com>2016-09-26 08:51:47 -0600
commiteb1ab91e1a12520d825cae60ee49655a0e8c4b94 (patch)
treeb9ed57a06489a57d4bc42cfd7ed3d80b7b1fec1a /CMakeLists.txt
parente7de858ce27ded585d6e2ec4a5cbc3467c6a7593 (diff)
downloadchill-eb1ab91e1a12520d825cae60ee49655a0e8c4b94.tar.gz
chill-eb1ab91e1a12520d825cae60ee49655a0e8c4b94.tar.bz2
chill-eb1ab91e1a12520d825cae60ee49655a0e8c4b94.zip
Node cleanup
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 284599f..5d6a26b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,10 @@ set(CORE_SRC
set(IR_CHILL_SRC
src/ir_clang.cc
+ )
+set(AST_CHILL_SRC
src/chillASTs.cc
+ src/ast/node.cpp
)
set(PYTHON_SRC
@@ -91,6 +94,7 @@ add_executable(chill
${CORE_SRC}
${PYTHON_SRC}
${IR_CHILL_SRC}
+ ${AST_CHILL_SRC}
${PRINTER_SRC})
target_link_libraries(chill