summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDerick Huth <derickhuth@gmail.com>2015-05-07 14:41:10 -0600
committerDerick Huth <derickhuth@gmail.com>2015-05-07 14:41:10 -0600
commit6eb2b89896da66a77d0dcdf2d72b98c122826949 (patch)
tree6c8174dadfe11a2a515c29940872a02d81f8d990 /configure.ac
parente6b89c668036ff8424455d3d1d1a5d79a063fc92 (diff)
parentf5c39e4c6ff55520948c2ef331c968cd84b817d9 (diff)
downloadchill-6eb2b89896da66a77d0dcdf2d72b98c122826949.tar.gz
chill-6eb2b89896da66a77d0dcdf2d72b98c122826949.tar.bz2
chill-6eb2b89896da66a77d0dcdf2d72b98c122826949.zip
Merge pull request #6 from dhuth/master
Adding Autotool Files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac80
1 files changed, 49 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index f4ccc5a..6174151 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,41 +19,46 @@ AM_PATH_PYTHON([2.7],[
[`${PYTHON} -c "from distutils import sysconfig; print(sysconfig.get_python_inc())"`])
AC_SUBST([PYTHON_LIBDIR],
[`${PYTHON} -c "from distutils import sysconfig; print(sysconfig.get_config_var('LIBDIR'))"`])
- AC_SUBST([with_python],[yes])],[
- AC_SUBST([with_python],[no])])
+ AC_SUBST([python_builds],[yes])],[
+ AC_SUBST([python_builds],[no])])
+#AC_ARG_ENABLE([cuda],[
+# AS_HELP_STRING([--enable-cuda],[builds cudachill])],[
+# AS_IF([test "x$enableval" != xno],[
+# AC_SUBST([enable_cuda],[yes])])])
+
AC_ARG_ENABLE([cuda],[
- AS_HELP_STRING([--enable-cuda],[builds cudachill])],[
+ AS_HELP_STRING([--enable-cuda],[builds cudachill])
+ ],[
AS_IF([test "x$enableval" != xno],[
- AC_SUBST([enable_cuda],[yes])],[])])
-AM_CONDITIONAL([CUDACHILL_OPT],[test "$enable_cuda" = yes])
+ AC_SUBST([enable_cuda],[yes])])])
+
+AM_CONDITIONAL([CUDACHILL_OPT],[test "x$enable_cuda" == xyes])
AC_ARG_ENABLE([coverage],[
- AS_HELP_STRING([--enable-coverage],[enables coverage testing])],[
-
- AS_IF([test "x$enableval" != xno],[
+ AS_HELP_STRING([--enable-coverage],[enables coverage testing])
+ ],[
+ AS_IF(["x$enableval" != xno],[
AC_SUBST([enable_coverage],[yes])
AC_SUBST([CFLAGS],["-g -fprofile-arcs -ftest-coverage"])
AC_SUBST([CPPFLAGS],["-g -fprofile-arcs -ftest-coverage"])],[])])
-
-AC_ARG_WITH([lua],[
- AS_HELP_STRING([--with-lua],[set lua home])],[
- AC_SUBST([LUAHOME], [$withval])],[
- AC_SUBST([LUAHOME], ["${LUAHOME}"])])
-
AC_ARG_WITH([rose],[
- AS_HELP_STRING([--with-rose],[set rose home])],[
+ AS_HELP_STRING([--with-rose],[set rose home])
+ ],[
AC_SUBST([ROSEHOME], [$withval])
- AC_DEFINE([BUILD_ROSE],[],[Use ROSE])],[
+ AC_DEFINE([BUILD_ROSE],[],[Use ROSE])
+ ],[
AC_SUBST([ROSEHOME], ["${ROSEHOME}"])
AC_DEFINE([BUILD_ROSE],[],[Use ROSE])])
AC_ARG_WITH([boost],[
- AS_HELP_STRING([--with-boost],[set boost home])],[
- AC_SUBST([BOOSTHOME], [$withval])],[
+ AS_HELP_STRING([--with-boost],[set boost home])
+ ],[
+ AC_SUBST([BOOSTHOME], [$withval])
+ ],[
AC_SUBST([BOOSTHOME], ["${BOOSTHOME}"])])
AC_ARG_WITH([omega],[
@@ -61,27 +66,40 @@ AC_ARG_WITH([omega],[
AC_SUBST([OMEGAHOME], [$withval])],[
AC_SUBST([OMEGAHOME], ["$(pwd)/omega"])])
+AC_ARG_WITH([python],[
+ AS_HELP_STRING([--with-python],[set python as the interface languge])
+ ],[
+ AC_SUBST([interface_lang],[python])
+ ],[
+ AC_SUBST([interface_lang],[default])])
+
+AC_ARG_WITH([lua],[
+ AS_HELP_STRING([--with-lua],[set lua as the interface langauge.])],[
+ AC_SUBST([LUAHOME], ["${LUAHOME}"])
+ AC_SUBST([interface_lang], [lua])
+ ],[
+ AC_SUBST([LUAHOME], ["${LUAHOME}"])])
-AC_ARG_WITH([interface],[
- AS_HELP_STRING([--with-interface],[select interface language])],[
- AC_SUBST([interface_lang],[$withval])],[
- AC_SUBST([interface_lang],["default"])])
+#AC_ARG_WITH([interface],[
+# AS_HELP_STRING([--with-interface],[select interface language])],[
+# AC_SUBST([interface_lang],[$withval])],[
+# AC_SUBST([interface_lang],[default])])
-AS_IF([test "$interface_lang" = default],[
- AS_IF([test "$enable_cuda" != no],[
+AS_IF([test "x$interface_lang" == xdefault],[
+ AS_IF([test "x$enable_cuda" == xyes],[
AC_SUBST([use_python],[no])
AC_SUBST([use_lua],[yes])
],[
AC_SUBST([use_python],[no])
- AC_SUBST([use_lua],[no])])])
+ AC_SUBST([use_lua],[no])])],[])
-AS_IF([test "$interface_lang" = lua],[
- AC_SUBST([use_lua],[yes])])
-AS_IF([test "$interface_lang" = python],[
- AC_SUBST([use_python],[yes])])
+AS_IF([test "x$interface_lang" == xlua],[
+ AC_SUBST([use_lua],[yes])],[])
+AS_IF([test "x$interface_lang" == xpython],[
+ AC_SUBST([use_python],[yes])],[])
-AM_CONDITIONAL([PYTHON_OPT],[test "$use_python" = yes])
-AM_CONDITIONAL([LUA_OPT],[test "$use_lua" = yes])
+AM_CONDITIONAL([PYTHON_OPT],[test "x$use_python" == xyes])
+AM_CONDITIONAL([LUA_OPT],[test "x$use_lua" == xyes])
AC_CONFIG_HEADERS([include/config.h])
AC_CONFIG_FILES([Makefile])