summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordhuth <derickhuth@gmail.com>2015-04-06 18:46:00 -0600
committerdhuth <derickhuth@gmail.com>2015-04-06 18:46:00 -0600
commitd7e5507eb0ba59db706b95e78e75f3678864415b (patch)
tree39f9e72f19d87140d6dbb16df4cdf8a4310f4e3c /configure.ac
parent7e39433ddb5f3ac5298207d5f4e8072eb193fa7a (diff)
downloadchill-d7e5507eb0ba59db706b95e78e75f3678864415b.tar.gz
chill-d7e5507eb0ba59db706b95e78e75f3678864415b.tar.bz2
chill-d7e5507eb0ba59db706b95e78e75f3678864415b.zip
bugfix in configure script
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index f4ccc5a..e88b407 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,21 +19,21 @@ AM_PATH_PYTHON([2.7],[
[`${PYTHON} -c "from distutils import sysconfig; print(sysconfig.get_python_inc())"`])
AC_SUBST([PYTHON_LIBDIR],
[`${PYTHON} -c "from distutils import sysconfig; print(sysconfig.get_config_var('LIBDIR'))"`])
- AC_SUBST([with_python],[yes])],[
- AC_SUBST([with_python],[no])])
+ AC_SUBST([with_python],["yes"])],[
+ AC_SUBST([with_python],["no"])])
AC_ARG_ENABLE([cuda],[
AS_HELP_STRING([--enable-cuda],[builds cudachill])],[
AS_IF([test "x$enableval" != xno],[
AC_SUBST([enable_cuda],[yes])],[])])
-AM_CONDITIONAL([CUDACHILL_OPT],[test "$enable_cuda" = yes])
+AM_CONDITIONAL([CUDACHILL_OPT],[test "x$enable_cuda" == xyes])
AC_ARG_ENABLE([coverage],[
AS_HELP_STRING([--enable-coverage],[enables coverage testing])],[
- AS_IF([test "x$enableval" != xno],[
+ AS_IF(["x$enableval" != xno],[
AC_SUBST([enable_coverage],[yes])
AC_SUBST([CFLAGS],["-g -fprofile-arcs -ftest-coverage"])
AC_SUBST([CPPFLAGS],["-g -fprofile-arcs -ftest-coverage"])],[])])
@@ -65,23 +65,23 @@ AC_ARG_WITH([omega],[
AC_ARG_WITH([interface],[
AS_HELP_STRING([--with-interface],[select interface language])],[
AC_SUBST([interface_lang],[$withval])],[
- AC_SUBST([interface_lang],["default"])])
+ AC_SUBST([interface_lang],[default])])
-AS_IF([test "$interface_lang" = default],[
- AS_IF([test "$enable_cuda" != no],[
+AS_IF([test "x$interface_lang" == xdefault],[
+ AS_IF([test "x$enable_cuda" != xno],[
AC_SUBST([use_python],[no])
AC_SUBST([use_lua],[yes])
],[
AC_SUBST([use_python],[no])
- AC_SUBST([use_lua],[no])])])
+ AC_SUBST([use_lua],[no])])],[])
-AS_IF([test "$interface_lang" = lua],[
- AC_SUBST([use_lua],[yes])])
-AS_IF([test "$interface_lang" = python],[
- AC_SUBST([use_python],[yes])])
+AS_IF([test "x$interface_lang" == xlua],[
+ AC_SUBST([use_lua],[yes])],[])
+AS_IF([test "x$interface_lang" == xpython],[
+ AC_SUBST([use_python],[yes])],[])
-AM_CONDITIONAL([PYTHON_OPT],[test "$use_python" = yes])
-AM_CONDITIONAL([LUA_OPT],[test "$use_lua" = yes])
+AM_CONDITIONAL([PYTHON_OPT],[test "x$use_python" == xyes])
+AM_CONDITIONAL([LUA_OPT],[test "x$use_lua" == xyes])
AC_CONFIG_HEADERS([include/config.h])
AC_CONFIG_FILES([Makefile])