summaryrefslogtreecommitdiff
path: root/lib/chillcg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/chillcg/CMakeLists.txt')
-rw-r--r--lib/chillcg/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/chillcg/CMakeLists.txt b/lib/chillcg/CMakeLists.txt
new file mode 100644
index 0000000..b204c69
--- /dev/null
+++ b/lib/chillcg/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(CODEGEN_CHILL_SRC
+ src/CG_chillBuilder.cc
+ src/CG_chillRepr.cc
+ )
+
+include_directories(
+ include
+ ${OMEGA_INC}
+ )
+
+add_library(chillcg ${CODEGEN_CHILL_SRC})
+
+install(TARGETS chillcg
+ DESTINATION lib)
+
+install(DIRECTORY include/code_gen
+ DESTINATION include)