summaryrefslogtreecommitdiff
path: root/omegalib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'omegalib/CMakeLists.txt')
-rw-r--r--omegalib/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/omegalib/CMakeLists.txt b/omegalib/CMakeLists.txt
new file mode 100644
index 0000000..f8872b1
--- /dev/null
+++ b/omegalib/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.8)
+project(omegalib)
+
+if(NOT DEFINED ROSEHOME)
+ message( FATAL_ERROR "ROSEHOME is not set, try use -DROSEHOME" )
+endif()
+if (NOT DEFINED BOOSTHOME)
+ message( FATAL_ERROR "BOOSTHOME is not set, try use -DBOOSTHOME" )
+endif()
+
+set(OMEGAROOT ${PROJECT_SOURCE_DIR})
+
+add_subdirectory(omega_lib)
+add_subdirectory(code_gen)
+add_subdirectory(omega_calc)