summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJari Vetoniemi <mailRoxas@gmail.com>2015-09-21 22:50:54 +0300
committerJari Vetoniemi <mailRoxas@gmail.com>2015-09-21 22:50:54 +0300
commit092b6ed52d5617071a25befdc90cc1fd960fd685 (patch)
tree165816cb8f6b5c413e21820b56136a4cff9d0d5a /lib/CMakeLists.txt
parent064e937452e18e542f19fc77084283fa7c34c5d6 (diff)
parentecd7d4056f710bf76deb0cf9a4366636244ff2dd (diff)
downloadbemenu-092b6ed52d5617071a25befdc90cc1fd960fd685.tar.gz
bemenu-092b6ed52d5617071a25befdc90cc1fd960fd685.tar.bz2
bemenu-092b6ed52d5617071a25befdc90cc1fd960fd685.zip
Merge pull request #19 from sleep-walker/master
Respect install destinations set by variables
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 0c87bf8..72b48c5 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -1,3 +1,5 @@
+include(GNUInstallDirs)
+
# Sources
SET(BEMENU_SOURCE
menu.c
@@ -43,8 +45,8 @@ SET_TARGET_PROPERTIES(bemenu PROPERTIES
TARGET_LINK_LIBRARIES(bemenu dl)
# Install
-INSTALL(TARGETS bemenu DESTINATION lib)
-INSTALL(FILES bemenu.h DESTINATION include)
+INSTALL(TARGETS bemenu DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+INSTALL(FILES bemenu.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
# Unexport
SET(BEMENU_INCLUDES)