summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTomáš Čech <sleep_walker@suse.cz>2015-09-21 21:37:56 +0200
committerTomáš Čech <sleep_walker@suse.cz>2015-09-21 21:48:45 +0200
commitecd7d4056f710bf76deb0cf9a4366636244ff2dd (patch)
tree165816cb8f6b5c413e21820b56136a4cff9d0d5a /lib/CMakeLists.txt
parent064e937452e18e542f19fc77084283fa7c34c5d6 (diff)
downloadbemenu-ecd7d4056f710bf76deb0cf9a4366636244ff2dd.tar.gz
bemenu-ecd7d4056f710bf76deb0cf9a4366636244ff2dd.tar.bz2
bemenu-ecd7d4056f710bf76deb0cf9a4366636244ff2dd.zip
Respect install destinations set by variables
Use CMAKE_INSTALL_LIBDIR and CMAKE_INSTALL_INCLUDEDIR as destination base.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 0c87bf8..72b48c5 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -1,3 +1,5 @@
+include(GNUInstallDirs)
+
# Sources
SET(BEMENU_SOURCE
menu.c
@@ -43,8 +45,8 @@ SET_TARGET_PROPERTIES(bemenu PROPERTIES
TARGET_LINK_LIBRARIES(bemenu dl)
# Install
-INSTALL(TARGETS bemenu DESTINATION lib)
-INSTALL(FILES bemenu.h DESTINATION include)
+INSTALL(TARGETS bemenu DESTINATION "${CMAKE_INSTALL_LIBDIR}")
+INSTALL(FILES bemenu.h DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}")
# Unexport
SET(BEMENU_INCLUDES)