summaryrefslogtreecommitdiff
path: root/toy/CMakeLists.txt
diff options
context:
space:
mode:
authorTuowen Zhao <ztuowen@gmail.com>2019-04-27 19:05:25 -0600
committerTuowen Zhao <ztuowen@gmail.com>2019-04-27 19:05:25 -0600
commit0781257b2a8d544abdcce38824a9b8288a04800d (patch)
tree365cea96de343e354913f90b35fc944e4459b2e9 /toy/CMakeLists.txt
parent4127831a28e31ac53ffdb1d7e7a88dd7d6317c6e (diff)
downloadmlir-toy-0781257b2a8d544abdcce38824a9b8288a04800d.tar.gz
mlir-toy-0781257b2a8d544abdcce38824a9b8288a04800d.tar.bz2
mlir-toy-0781257b2a8d544abdcce38824a9b8288a04800d.zip
Split toy dialect using static registration
Diffstat (limited to 'toy/CMakeLists.txt')
-rw-r--r--toy/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/toy/CMakeLists.txt b/toy/CMakeLists.txt
new file mode 100644
index 0000000..1c7826e
--- /dev/null
+++ b/toy/CMakeLists.txt
@@ -0,0 +1,6 @@
+file(GLOB globbed *.c *.cpp)
+add_llvm_library(ToyDialect
+ ${globbed}
+ )
+#add_dependencies(MLIRStandardOps MLIRStandardOpsIncGen LLVMSupport)
+#target_link_libraries(MLIRStandardOps LLVMSupport)